Technology Tracking ...

Jetspeed2 Installation Quickstart

Here I will write a Quick Start For Impatient this article are based on the article written on th JetSpeed2 Wiki Page but it addresses and solves the problems that this wiki pages didn't mentioned.

Requirements

  • JDK 1.5.0 (Required by Tomcat 5.5)
  • Maven 1.0.2
  • Tomcat 5.5.12
  • Subversion 1.2.1
  • Jetspeed 2 Source code
  • Apache-ant-1.6.5

Note that other versions of Java, Maven, Subversion, Ant, and Tomcat may work. These are the versions used to create this guide on Suse 9.2.

Jetspeed Source

 svn co http://svn.apache.org/repos/asf/portals/jetspeed-2/trunk jetspeed-2

Environment Settings

Set the following environment variables (JRE_HOME is needed by Tomcat 5.5).

Tomcat Authentication with LDAP


 All you have to do if You want to make Tomcat Authenticat 
 with LDAP for Your WebApplication is.

Follow the following three steps:

1. Copy the ldap.jar:

 copy the ldap jar into 
   /usr/java/tomcat5/common/lib or
   /usr/java/tomcat5/server/lib
 The difference between those two paths is that 
 The First one make the jar accessable to both the webApplication
 and the server.
 The Second one make the jar accessable to the server only.

 Note: 
  

Powered by Drupal - Design by artinet